[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Pspp-commits] [SCM] GNU PSPP branch, master, updated. v0.6.1-2280-g0964
From: |
Ben Pfaff |
Subject: |
[Pspp-commits] [SCM] GNU PSPP branch, master, updated. v0.6.1-2280-g09648bd |
Date: |
Thu, 10 Nov 2011 05:36:30 +0000 |
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "GNU PSPP".
The branch, master has been updated
via 09648bd73c7511f3c70c941b77f559569edae292 (commit)
via d63cd372d504572e38bab5f5b9c4f81b6edde5ed (commit)
via 4b938f84aa68af17d5f7487523ad2a478abb7b6d (commit)
via e91b6c7d11cfeaf1619224f6a14fb4be86690aa4 (commit)
from 7235f7f42b61c2b111174c3ee5ca72aac8815cd5 (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit 09648bd73c7511f3c70c941b77f559569edae292
Author: Ben Pfaff <address@hidden>
Date: Wed Nov 9 21:27:41 2011 -0800
GET: Fix confusion over the type of the 'type' parameter.
The 'type' parameter was being used to pass in an "enum reader_command" but
it was then later assigned a value of "enum pfm_type". This renames 'type'
to 'command' for clarity and just deletes the assignment of the "enum
pfm_type" value entirely because the value was not used.
Found by Clang.
Reported-by: Jeremy Lavergne <address@hidden>
commit d63cd372d504572e38bab5f5b9c4f81b6edde5ed
Author: Ben Pfaff <address@hidden>
Date: Wed Nov 9 21:23:46 2011 -0800
DO REPEAT: Properly convert lex_syntax_mode to segmenter_mode.
Clang reported that "enum lex_syntax_mode" was being implicitly converted
to "enum segmenter_mode". Luckily, equal values in each enum have the
same meaning, but it seems better to convert by hand, so this patch
implements that.
Reported-by: Jeremy Lavergne <address@hidden>
commit 4b938f84aa68af17d5f7487523ad2a478abb7b6d
Author: Ben Pfaff <address@hidden>
Date: Wed Nov 9 21:16:19 2011 -0800
hmap: Mark definition of hmap_node_hash() "static inline".
This suppresses a Clang warning. The prototype earlier in the file
was already marked "static inline", so I don't think that this is a
functional change.
Reported-by: Jeremy Lavergne <address@hidden>
commit e91b6c7d11cfeaf1619224f6a14fb4be86690aa4
Author: Ben Pfaff <address@hidden>
Date: Wed Nov 9 21:02:06 2011 -0800
str: Mark definition of ss_empty() "static inline".
This suppresses a Clang warning. The prototype earlier in the file
was already marked "static inline", so I don't think that this is a
functional change.
Reported-by: Jeremy Lavergne <address@hidden>
-----------------------------------------------------------------------
Summary of changes:
src/language/control/repeat.c | 21 ++++++++++++++++-----
src/language/data-io/get.c | 12 +++++-------
src/libpspp/hmap.h | 2 +-
src/libpspp/str.h | 2 +-
4 files changed, 23 insertions(+), 14 deletions(-)
hooks/post-receive
--
GNU PSPP
[Prev in Thread] |
Current Thread |
[Next in Thread] |
- [Pspp-commits] [SCM] GNU PSPP branch, master, updated. v0.6.1-2280-g09648bd,
Ben Pfaff <=