[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Pspp-commits] [SCM] GNU PSPP branch, master, updated. v0.6.1-1906-g2568
From: |
Ben Pfaff |
Subject: |
[Pspp-commits] [SCM] GNU PSPP branch, master, updated. v0.6.1-1906-g2568149 |
Date: |
Wed, 23 Feb 2011 05:22:13 +0000 |
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "GNU PSPP".
The branch, master has been updated
via 2568149f70a8866f4875132e328d7f2d56e76038 (commit)
via a124375065d0768546f6e7670d9c6d6a0b2b5379 (commit)
via 20751c90d1d6131fede84358ea2581d9ed443ae3 (commit)
via 068a4cbf264102f4ede4c3805eecbacf15f0f2d8 (commit)
via 4e8257086ffc71bc5a1785fd86610921be677887 (commit)
via c41cd1fefc98bb4abed33754276d93db9ffe2e0e (commit)
via 6bf6119d76b761cbbca0ca9e5b680f419eaf937b (commit)
via 2b0538e3901bfc1301729ab5b84e4d3e05ee4ccc (commit)
via bdebbd4db2d6c539eadb145f726382fe338e4219 (commit)
via bc19562deb692e6db3271eb0402e9f9c99e4cbcb (commit)
via 28bebf0851bac332b55cdc03e55165dcc8e713c2 (commit)
via f9d0b49f59af300be5600141a0096b26c96abce9 (commit)
via b4e0254416c503fc11eb2fd16ea913ae2f415890 (commit)
via dba1133f9a29a8a8f806a824e884f99136ceb9fc (commit)
from 18e0d701a5e9a288604a408100efcf1463b6da9c (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit 2568149f70a8866f4875132e328d7f2d56e76038
Author: Ben Pfaff <address@hidden>
Date: Sat Feb 19 17:30:39 2011 -0800
data-out: Add test for non-ASCII custom currency formats.
These now work as I would expect, so add a test to avoid future regression.
commit a124375065d0768546f6e7670d9c6d6a0b2b5379
Author: Ben Pfaff <address@hidden>
Date: Sat Feb 19 12:55:54 2011 -0800
data-out: Optimize and fix some bad assumptions.
Until now, data_out_pool() and its wrapper function data_out() have always
done at least two memory allocations: one to fill in the initial version
of the result and another to recode it to UTF-8. However, recoding to
UTF-8 is usually unnecessary, because most output formats always produce
output in UTF-8 anyway. Only binary formats and the string A format ever
produce data in other encodings, so this commit drops recoding entirely
except for those cases. Binary formats are a particularly special case:
usually it doesn't make any sense to use these formats for text output,
but this commit does its best to translate the binary output bytes into
valid UTF-8, at least up to the first null byte.
This commit also finishes fixing up display widths.
The closely related data_out_legacy() function, which only has one user
in three also needed some work. It was badly named, so I renamed it to
data_out_recode(). It made the bad assumption that the data passed in
was encoded in ASCII (written C_ENCODING). It also made the bad
assumption that the number of bytes output would be exactly the format's
width. This rewrite fixes these problems.
commit 20751c90d1d6131fede84358ea2581d9ed443ae3
Author: Ben Pfaff <address@hidden>
Date: Fri Feb 18 21:58:08 2011 -0800
pool: Support NULL pool argument to pool_alloc_unaligned().
I don't see a reason that this should be unsupported.
commit 068a4cbf264102f4ede4c3805eecbacf15f0f2d8
Author: Ben Pfaff <address@hidden>
Date: Wed Feb 16 21:42:13 2011 -0800
data-out: Reorganize output_Z() to be more easily understood.
It took me a minute to figure out what was going on here, so this commit
slightly reorganizes it.
commit 4e8257086ffc71bc5a1785fd86610921be677887
Author: Ben Pfaff <address@hidden>
Date: Fri Feb 18 21:55:18 2011 -0800
format: Count prefix and suffix width in terms of display columns.
Until now, the prefixes and suffixes for custom currency formats
(CCA, etc.) have been considered to occupy one display column per
byte. This is fine for prefixes and suffixes like "$" or "%", but
falls down badly with U+00A5 (Â¥) or U+20AC (â¬), which occupy two
or three bytes, respectively, in UTF-8, while occupying only a
single display column.
This commit fixes the problem. It doesn't add a test yet because
there are still some higher-level issues, but that will come in
a later commit when those remaining issues are resolved.
commit c41cd1fefc98bb4abed33754276d93db9ffe2e0e
Author: Ben Pfaff <address@hidden>
Date: Tue Feb 15 22:00:33 2011 -0800
format: Create a new "struct fmt_affix" for prefix and suffix strings.
This combines two changes: changing the string type for numeric
prefix and suffix strings from "struct substring" to plain "char *",
and putting the string inside a new structure. Both of these will
make more sense after the following commit, which adds another member
to the new structure and stops using the length of the string in so
many places (which is the reason that "struct substring" was a good
choice).
commit 6bf6119d76b761cbbca0ca9e5b680f419eaf937b
Author: Ben Pfaff <address@hidden>
Date: Fri Feb 18 22:30:00 2011 -0800
data-out: Make each converter responsible for storing null terminator.
Until now, every converter has produced output that is exactly as many
bytes long as the format's width. In upcoming patches this will change,
because in UTF-8 a character that occupies a single display column can
require multiple bytes. In preparation, this commit requires the
individual converters to write out their own null byte, giving a bit
more flexibility regarding length.
commit 2b0538e3901bfc1301729ab5b84e4d3e05ee4ccc
Author: Ben Pfaff <address@hidden>
Date: Mon Feb 14 23:17:11 2011 -0800
format: Increase abstraction of fmt_number_style.
Upcoming commits will make some changes to fmt_number_style, so it
seems best to avoid having clients actually construct and modify
instances of this structure. This commit makes that change.
We could take it one step further and add accessor functions even
for reading out the structure, but in my opinion that would be
overkill for this structure.
commit bdebbd4db2d6c539eadb145f726382fe338e4219
Author: Ben Pfaff <address@hidden>
Date: Sun Feb 13 11:23:06 2011 -0800
legacy-encoding: Remove.
The functions in this module are no longer used.
commit bc19562deb692e6db3271eb0402e9f9c99e4cbcb
Author: Ben Pfaff <address@hidden>
Date: Sun Feb 13 11:49:30 2011 -0800
i18n: Introduce C_ENCODING as replacement for LEGACY_NATIVE.
The LEGACY_NATIVE name seems a bit awkward for something that is just the
name of the encoding for strings in C source code, that is, the C locale,
so this commit renames it to C_ENCODING and moves it to i18n.h with the
rest of the encoding-related functions.
In addition, PSPP assumes in various places that the local system has
ASCII-based locales. I don't think there's much point in pretending to
support EBCDIC, so this commit removes that little bit of support.
commit 28bebf0851bac332b55cdc03e55165dcc8e713c2
Author: Ben Pfaff <address@hidden>
Date: Sun Feb 13 11:36:27 2011 -0800
i18n: New function recode_byte().
commit f9d0b49f59af300be5600141a0096b26c96abce9
Author: Ben Pfaff <address@hidden>
Date: Sat Feb 19 16:55:58 2011 -0800
PRINT: Use UTF-8 encoding for output to the output subsystem.
All string data coming into the output subsystem must be encoded in UTF-8,
but PRINT was recoding it into ASCII instead.
commit b4e0254416c503fc11eb2fd16ea913ae2f415890
Author: Ben Pfaff <address@hidden>
Date: Mon Feb 14 22:04:51 2011 -0800
CROSSTABS: Eliminate redundant data copying.
There's no point in copying the output string twice.
commit dba1133f9a29a8a8f806a824e884f99136ceb9fc
Author: Ben Pfaff <address@hidden>
Date: Sun Feb 13 22:20:45 2011 -0800
Use new Gnulib function dtoastr() to format short, accurate real numbers.
%.*g with DBL_DIG + 1 as argument is simple but in rare cases it fails to
accurately format a real number. The recently added Gnulib routine
dtoastr() always formats a real number accurately, so switch to using it
for these cases.
-----------------------------------------------------------------------
Summary of changes:
Smake | 2 +
doc/dev/concepts.texi | 5 -
src/data/csv-file-writer.c | 8 +-
src/data/data-in.c | 21 ++--
src/data/data-in.h | 3 +-
src/data/data-out.c | 209 +++++++++++++++++++++----------
src/data/data-out.h | 9 +-
src/data/file-handle-def.c | 7 +-
src/data/file-handle-def.h | 3 +-
src/data/format.c | 162 +++++++++++++-----------
src/data/format.h | 41 ++++---
src/data/settings.c | 60 +++++-----
src/language/data-io/data-reader.h | 3 +-
src/language/data-io/print.c | 18 ++--
src/language/expressions/helpers.h | 1 +
src/language/expressions/operations.def | 6 +-
src/language/lexer/value-parser.c | 6 +-
src/language/stats/crosstabs.q | 13 +--
src/language/utilities/set.q | 16 ++--
src/language/xforms/recode.c | 5 +-
src/libpspp/automake.mk | 2 -
src/libpspp/i18n.c | 16 +++-
src/libpspp/i18n.h | 7 +
src/libpspp/legacy-encoding.c | 41 ------
src/libpspp/legacy-encoding.h | 34 -----
src/libpspp/pool.c | 5 +-
src/output/tab.c | 7 +-
src/ui/gui/text-data-import-dialog.c | 4 +-
src/ui/syntax-gen.c | 24 ++---
tests/data/data-out.at | 36 ++++++
30 files changed, 420 insertions(+), 354 deletions(-)
delete mode 100644 src/libpspp/legacy-encoding.c
delete mode 100644 src/libpspp/legacy-encoding.h
hooks/post-receive
--
GNU PSPP
[Prev in Thread] |
Current Thread |
[Next in Thread] |
- [Pspp-commits] [SCM] GNU PSPP branch, master, updated. v0.6.1-1906-g2568149,
Ben Pfaff <=